Discussion:
JUL class name
Gary Gregory
2014-09-08 12:41:51 UTC
Permalink
WRT org.apache.logging.log4j.jul.Levels

I think these would be better names:

Levels -> org.apache.logging.log4j.jul.LevelConverter
- toJulLevel
- toLog4jLevel

Gary
--
E-Mail: ***@gmail.com | ***@apache.org
Java Persistence with Hibernate, Second Edition
<http://www.manning.com/bauer3/>
JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
Spring Batch in Action <http://www.manning.com/templier/>
Blog: http://garygregory.wordpress.com
Home: http://garygregory.com/
Tweet! http://twitter.com/GaryGregory
Gary Gregory
2014-09-08 12:45:07 UTC
Permalink
Also, why not use maps to implement the conversions?

Gary
Post by Gary Gregory
WRT org.apache.logging.log4j.jul.Levels
Levels -> org.apache.logging.log4j.jul.LevelConverter
- toJulLevel
- toLog4jLevel
Gary
--
Java Persistence with Hibernate, Second Edition
<http://www.manning.com/bauer3/>
JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
Spring Batch in Action <http://www.manning.com/templier/>
Blog: http://garygregory.wordpress.com
Home: http://garygregory.com/
Tweet! http://twitter.com/GaryGregory
--
E-Mail: ***@gmail.com | ***@apache.org
Java Persistence with Hibernate, Second Edition
<http://www.manning.com/bauer3/>
JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
Spring Batch in Action <http://www.manning.com/templier/>
Blog: http://garygregory.wordpress.com
Home: http://garygregory.com/
Tweet! http://twitter.com/GaryGregory
Matt Sicker
2014-09-08 13:48:32 UTC
Permalink
Post by Gary Gregory
Also, why not use maps to implement the conversions?
For standard level lookups? Because the ranges are for custom level
support. Plus, the name change sounds good. Just can't make it a
TypeConverter sadly.
Post by Gary Gregory
Gary
Post by Gary Gregory
WRT org.apache.logging.log4j.jul.Levels
Levels -> org.apache.logging.log4j.jul.LevelConverter
- toJulLevel
- toLog4jLevel
Gary
--
Java Persistence with Hibernate, Second Edition
<http://www.manning.com/bauer3/>
JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
Spring Batch in Action <http://www.manning.com/templier/>
Blog: http://garygregory.wordpress.com
Home: http://garygregory.com/
Tweet! http://twitter.com/GaryGregory
--
Java Persistence with Hibernate, Second Edition
<http://www.manning.com/bauer3/>
JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
Spring Batch in Action <http://www.manning.com/templier/>
Blog: http://garygregory.wordpress.com
Home: http://garygregory.com/
Tweet! http://twitter.com/GaryGregory
--
Matt Sicker <***@gmail.com>
Gary Gregory
2014-09-08 13:56:54 UTC
Permalink
For == tests, a map seems better.

Gary
Post by Matt Sicker
Post by Gary Gregory
Also, why not use maps to implement the conversions?
For standard level lookups? Because the ranges are for custom level
support. Plus, the name change sounds good. Just can't make it a
TypeConverter sadly.
Post by Gary Gregory
Gary
Post by Gary Gregory
WRT org.apache.logging.log4j.jul.Levels
Levels -> org.apache.logging.log4j.jul.LevelConverter
- toJulLevel
- toLog4jLevel
Gary
--
Java Persistence with Hibernate, Second Edition
<http://www.manning.com/bauer3/>
JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
Spring Batch in Action <http://www.manning.com/templier/>
Blog: http://garygregory.wordpress.com
Home: http://garygregory.com/
Tweet! http://twitter.com/GaryGregory
--
Java Persistence with Hibernate, Second Edition
<http://www.manning.com/bauer3/>
JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
Spring Batch in Action <http://www.manning.com/templier/>
Blog: http://garygregory.wordpress.com
Home: http://garygregory.com/
Tweet! http://twitter.com/GaryGregory
--
--
E-Mail: ***@gmail.com | ***@apache.org
Java Persistence with Hibernate, Second Edition
<http://www.manning.com/bauer3/>
JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
Spring Batch in Action <http://www.manning.com/templier/>
Blog: http://garygregory.wordpress.com
Home: http://garygregory.com/
Tweet! http://twitter.com/GaryGregory
Matt Sicker
2014-09-08 13:57:56 UTC
Permalink
Post by Gary Gregory
For == tests, a map seems better.
Gary
I agree.
Post by Gary Gregory
Post by Matt Sicker
Post by Gary Gregory
Also, why not use maps to implement the conversions?
For standard level lookups? Because the ranges are for custom level
support. Plus, the name change sounds good. Just can't make it a
TypeConverter sadly.
Post by Gary Gregory
Gary
Post by Gary Gregory
WRT org.apache.logging.log4j.jul.Levels
Levels -> org.apache.logging.log4j.jul.LevelConverter
- toJulLevel
- toLog4jLevel
Gary
--
Java Persistence with Hibernate, Second Edition
<http://www.manning.com/bauer3/>
JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
Spring Batch in Action <http://www.manning.com/templier/>
Blog: http://garygregory.wordpress.com
Home: http://garygregory.com/
Tweet! http://twitter.com/GaryGregory
--
Java Persistence with Hibernate, Second Edition
<http://www.manning.com/bauer3/>
JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
Spring Batch in Action <http://www.manning.com/templier/>
Blog: http://garygregory.wordpress.com
Home: http://garygregory.com/
Tweet! http://twitter.com/GaryGregory
--
--
Java Persistence with Hibernate, Second Edition
<http://www.manning.com/bauer3/>
JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
Spring Batch in Action <http://www.manning.com/templier/>
Blog: http://garygregory.wordpress.com
Home: http://garygregory.com/
Tweet! http://twitter.com/GaryGregory
--
Matt Sicker <***@gmail.com>
Gary Gregory
2014-09-08 14:08:19 UTC
Permalink
Post by Matt Sicker
Post by Gary Gregory
For == tests, a map seems better.
Gary
I agree.
Do you have time?

Gary
Post by Matt Sicker
Post by Gary Gregory
Post by Matt Sicker
Post by Gary Gregory
Also, why not use maps to implement the conversions?
For standard level lookups? Because the ranges are for custom level
support. Plus, the name change sounds good. Just can't make it a
TypeConverter sadly.
Post by Gary Gregory
Gary
Post by Gary Gregory
WRT org.apache.logging.log4j.jul.Levels
Levels -> org.apache.logging.log4j.jul.LevelConverter
- toJulLevel
- toLog4jLevel
Gary
--
Java Persistence with Hibernate, Second Edition
<http://www.manning.com/bauer3/>
JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
Spring Batch in Action <http://www.manning.com/templier/>
Blog: http://garygregory.wordpress.com
Home: http://garygregory.com/
Tweet! http://twitter.com/GaryGregory
--
Java Persistence with Hibernate, Second Edition
<http://www.manning.com/bauer3/>
JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
Spring Batch in Action <http://www.manning.com/templier/>
Blog: http://garygregory.wordpress.com
Home: http://garygregory.com/
Tweet! http://twitter.com/GaryGregory
--
--
Java Persistence with Hibernate, Second Edition
<http://www.manning.com/bauer3/>
JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
Spring Batch in Action <http://www.manning.com/templier/>
Blog: http://garygregory.wordpress.com
Home: http://garygregory.com/
Tweet! http://twitter.com/GaryGregory
--
--
E-Mail: ***@gmail.com | ***@apache.org
Java Persistence with Hibernate, Second Edition
<http://www.manning.com/bauer3/>
JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
Spring Batch in Action <http://www.manning.com/templier/>
Blog: http://garygregory.wordpress.com
Home: http://garygregory.com/
Tweet! http://twitter.com/GaryGregory
Matt Sicker
2014-09-08 16:16:05 UTC
Permalink
Yes actually. Last day off.
Post by Gary Gregory
Post by Matt Sicker
Post by Gary Gregory
For == tests, a map seems better.
Gary
I agree.
Do you have time?
Gary
Post by Matt Sicker
Post by Gary Gregory
Post by Matt Sicker
Post by Gary Gregory
Also, why not use maps to implement the conversions?
For standard level lookups? Because the ranges are for custom level
support. Plus, the name change sounds good. Just can't make it a
TypeConverter sadly.
Post by Gary Gregory
Gary
Post by Gary Gregory
WRT org.apache.logging.log4j.jul.Levels
Levels -> org.apache.logging.log4j.jul.LevelConverter
- toJulLevel
- toLog4jLevel
Gary
--
Java Persistence with Hibernate, Second Edition
<http://www.manning.com/bauer3/>
JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
Spring Batch in Action <http://www.manning.com/templier/>
Blog: http://garygregory.wordpress.com
Home: http://garygregory.com/
Tweet! http://twitter.com/GaryGregory
--
Java Persistence with Hibernate, Second Edition
<http://www.manning.com/bauer3/>
JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
Spring Batch in Action <http://www.manning.com/templier/>
Blog: http://garygregory.wordpress.com
Home: http://garygregory.com/
Tweet! http://twitter.com/GaryGregory
--
--
Java Persistence with Hibernate, Second Edition
<http://www.manning.com/bauer3/>
JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
Spring Batch in Action <http://www.manning.com/templier/>
Blog: http://garygregory.wordpress.com
Home: http://garygregory.com/
Tweet! http://twitter.com/GaryGregory
--
--
Java Persistence with Hibernate, Second Edition
<http://www.manning.com/bauer3/>
JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
Spring Batch in Action <http://www.manning.com/templier/>
Blog: http://garygregory.wordpress.com
Home: http://garygregory.com/
Tweet! http://twitter.com/GaryGregory
--
Matt Sicker <***@gmail.com>
Gary Gregory
2014-09-08 16:32:43 UTC
Permalink
Enjoy :-)

G
Post by Matt Sicker
Yes actually. Last day off.
Post by Gary Gregory
Post by Matt Sicker
Post by Gary Gregory
For == tests, a map seems better.
Gary
I agree.
Do you have time?
Gary
Post by Matt Sicker
Post by Gary Gregory
Post by Matt Sicker
Post by Gary Gregory
Also, why not use maps to implement the conversions?
For standard level lookups? Because the ranges are for custom level
support. Plus, the name change sounds good. Just can't make it a
TypeConverter sadly.
Post by Gary Gregory
Gary
Post by Gary Gregory
WRT org.apache.logging.log4j.jul.Levels
Levels -> org.apache.logging.log4j.jul.LevelConverter
- toJulLevel
- toLog4jLevel
Gary
--
Java Persistence with Hibernate, Second Edition
<http://www.manning.com/bauer3/>
JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
Spring Batch in Action <http://www.manning.com/templier/>
Blog: http://garygregory.wordpress.com
Home: http://garygregory.com/
Tweet! http://twitter.com/GaryGregory
--
Java Persistence with Hibernate, Second Edition
<http://www.manning.com/bauer3/>
JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
Spring Batch in Action <http://www.manning.com/templier/>
Blog: http://garygregory.wordpress.com
Home: http://garygregory.com/
Tweet! http://twitter.com/GaryGregory
--
--
Java Persistence with Hibernate, Second Edition
<http://www.manning.com/bauer3/>
JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
Spring Batch in Action <http://www.manning.com/templier/>
Blog: http://garygregory.wordpress.com
Home: http://garygregory.com/
Tweet! http://twitter.com/GaryGregory
--
--
Java Persistence with Hibernate, Second Edition
<http://www.manning.com/bauer3/>
JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
Spring Batch in Action <http://www.manning.com/templier/>
Blog: http://garygregory.wordpress.com
Home: http://garygregory.com/
Tweet! http://twitter.com/GaryGregory
--
--
E-Mail: ***@gmail.com | ***@apache.org
Java Persistence with Hibernate, Second Edition
<http://www.manning.com/bauer3/>
JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
Spring Batch in Action <http://www.manning.com/templier/>
Blog: http://garygregory.wordpress.com
Home: http://garygregory.com/
Tweet! http://twitter.com/GaryGregory
Loading...